新闻资讯

企业私有网中配置VLAN命令实例分享,企业私有网如何实现?

2020-07-2

很多企业都会组建自己的企业私有网络,方便办公和内部沟通。 构建和运维一个企业私有网络,需要做哪些工作呢?小编为大家整理了一个企业私有网中配置VLAN命令实例分享。

企业私有网中配置VLAN命令实例分享

先设计一个企业私有网拓扑结构!

为了表述清晰,拓扑图设计解读:在交换机上创建VLAN10 ,VLAN20针对PC机配置端口类型access,针对交换机S2,S3配置端口类型trunk,我们要将接口加入对应的VLAN。

因为设备是仿真设备,因此连接完成后,激活设备。

我们开启网络设备后,观察S1交换机,我们会发现S1有四个端口,连接两台PC机和两台交换机。

科普文,在企业私有网中,配置VLAN命令实例分享
根据拓扑图配置交换机S1,过程如下!

第一步!对S1进行必要的设置,修改名字,创建VLAN。

[S1]sysname S1(修改交换机名字。)

[S1]vlan batch 10 20(在 S1 上创建二个 VLAN。)

[S1]display vlan (查看交换机的VLAN。)

第二步!交换机S1连接pc1接口,确定为 access 模式,并加入相应的 VLAN10。

[S1]interface g0/0/1(S1连接pc1接口)

[S1-GigabitEthernet0/0/1]port link-type access(确定为 access 模式)[S1-GigabitEthernet0/0/1]port default vlan 10(并加入相应的 VLAN10)

第三步!交换机S1连接pc2接口,确定为 access 模式,并加入相应的 VLAN20。

[S1]interface g0/0/2(S1连接pc2接口)

[S1-GigabitEthernet0/0/2]port link-type access(确定为 access 模式)[S1-GigabitEthernet0/0/2]port default vlan 10(并加入相应的 VLAN20)

第四步!再把 交换机S1 与 S3 之间的链路配置成 trunk。Trunk 接口默认只允许 VLAN 1 通过,配置允许 VLAN10、VLAN20 通过.

[S1]interface g0/0/3

[S1-GigabitEthernet0/0/3]port link-type trunk( S1 与 S3 之间的链路配置成 trunk)

[S1-GigabitEthernet0/0/3]port trunk allow-pass vlan 10 20(配置允许 VLAN10、VLAN20 通过。)

第五步!再把交换机 S1 与 S2 之间的链路配置成 trunk。配置允许 VLAN10、VLAN20 通过.

[S1]interface g0/0/4

[S1-GigabitEthernet0/0/4]port link-type trunk( S1 与 S3 之间的链路配置成 trunk)

[S1-GigabitEthernet0/0/4]port trunk allow-pass vlan 10 20(配置允许 VLAN10、VLAN20 )

第六步!测设配置内容是否成功。

验证 VLAN 的配置,使用命令display vlan summary。

查看接口属于的 VLAN,命令display port vlan。

科普文,在企业私有网中,配置VLAN命令实例分享。

实现企业私有网 推荐蒲公英

1、产品清单
(1)蒲公英路由器X3
(2)蒲公英异地组网客户端

2、方案部署
利用蒲公英进行智能组网
小王将网线连接公司路由器的LAN口和蒲公英的WAN口,并接通电源,目前电脑已正常上网。按照教程在浏览器输入“http://oraybox.com” 先进行路由器的初始化。

初始化之后,点击【智能组网】——【成员列表】——【绑定帐号】,将路由器绑定到自己的帐号下。

下一步进入蒲公英组网管理界面p.oray.com,点击【异地组网网络】——【立即创建网络】,添加蒲公英路由器以及添加异地组网客户端,并且下载蒲公英异地组网客户端软件进行登录。

登录蒲公英客户端之后,会分配一个虚拟IP,右击路由器进行Ping,测试是否正常。

目前路由器下有连接一台电脑,IP地址为10.168.1.157,ping测试也能够成功。

小王在家里的电脑登录蒲公英异地组网客户端,并测试已跟公司的电脑互联互通。
目前FTP已连接成功。不管是家里还是在外出差,都可以使用FTP,使用非常方便。

3、方案优点
1、组网功能操作简单,无需管理路由器,网络小白也能轻易上手;
2、蒲公英异地组网客户端支持多平台,网络兼容性强,能灵活使用;
3、连接稳定,速度快,犹如在公司访FTP的资料一样,在家办公也能方便访问。

注意事项

1、添加旁路若目标类型选择的是“IP网络段”,子网掩码也要跟随变化;
2、客户端与公司的设备无法ping通时,需留意电脑防火墙和杀毒软件是否已经关闭。

蒲公英路由器主打的异地组网功能不仅适用于网络结构复杂的环境,而且具有成本低、技术要求低、数据传输安全、灵活性高等优势。对于、企业来说无疑是个高效、可靠的方法,轻松搞定远程访问难题,实现各类项目、数据的异地管理及同步。